Possible Double Rewards

Incident Report for Punchh Yum UK

Resolved

This incident has been resolved.
Posted Aug 06, 2025 - 16:44 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Aug 06, 2025 - 15:23 PDT

Investigating

Data synchronization issue allowed some guests to double redeem their loyalty rewards.
We have identified a data synchronization issue that may have allowed some guests to redeem the same loyalty reward more than once.

* This issue could potentially result in duplicate redemptions and unexpected reward utilization for affected businesses.
* Our team is currently conducting a thorough investigation to quantify the exact impact per brand and ensure all affected records are properly reconciled.
* We are working diligently to implement safeguards to prevent recurrence of this issue
.
If you believe your brand may be impacted or require more details, please contact your designated **Customer Success Manager or Support Representative** for personalized assistance.

We appreciate your patience as we complete our investigation and will provide updates as more information becomes available.
Posted Aug 06, 2025 - 15:03 PDT